已知面积求周长

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
 

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.
Tleq 10,nleq {10}^{9}
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

3
2
7
12
 

Sample Output

6
16
14
程序分析:此题的题意由标题就可以知道是已知一个矩形的面积要我们求周长,但值得注意的是要求我们求最小的周长,所以我们要使有一个变量min保存最小周长。使用的方法就是令2*(1+N)为最小周长,然后如果发现还有更有的周长就把这个值赋给min,最后输出min即可。
程序代码:
#include<iostream>
using namespace std;

int main()
{
    int T,n,j,b,min;
    cin>>T;
    while(T--)
    { 
        cin>>n;
        min=2*(1+n);
        for(int i=2;i<i*i;i++)
        {
            if(n%i==0)
            {
                b=n/i;
                j=(2*(i+b));
              if(min>j)
                  min=j;
            }

        }
        cout<<min<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/yilihua/p/4693088.html