ZOJ Problem Set

ZOJ Problem Set - 1003
Crashing Balloon

Time Limit: 2 Seconds      Memory Limit: 65536 KB

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports hisher score, the product of the numbers on the balloons heshe's crashed.  The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge hisher opponent's score.  The player with the lower score is presumed to have told the truth, because if heshe were to lie about hisher score, heshe would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that heshe could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
62


思路:两个数字必须使用同一个因子进行分解时,分数最小的获胜,
可以不使用同一因子进行分解并且,两个数字都可以分解到 1(被完全分解)时,大的分数获胜。
#include <iostream>
#include <algorithm>

using namespace std ; 

bool flag1 , flag2 ; 
int num1 , num2 ; 

void dfs(int a , int b , int i){
    if(flag2 == true && flag1 == true){
        return;
    }
    if(i>100){
        return;
    }
    if(b == 1){
        // 在最小数分解成功之后,最大数本分解成功才是正确的
        if(a == 1){
            flag1 = true ; 
        }
        flag2 = true ; 
    }
    // 深搜时两个数字不使用同一因子进行分解
    // 两个数字必须使用同一因子分解才能得到1时,小的获胜
    if(b % i == 0 ){
        dfs(a , b/i , i + 1) ; 
    }
    if(a % i == 0 ){
        dfs(a/i , b , i + 1) ; 
    }
    dfs(a , b , i + 1) ; 
}

int main(){

    while(cin >> num1 >> num2){
        if(num1 < num2){
            swap(num1 , num2) ; 
        }

        flag1 = flag2 = false ; 
        dfs(num1 , num2 , 2) ; 

        if(flag1==false && flag2 == true){
            cout << num2 << endl ; 
        }else{

            cout << num1 << endl ; 
        }
    }
    return 0 ; 
}
// 借鉴的从大到小因数分解
#include <iostream> #include <cstdio> #include <cstring> using namespace std; bool aTrue, bTrue; /** 判断a, b有没有公共的因子,如果有,那么分数低的胜,如果没有,那么分数高的获胜 如果分数在2-100之间,那么就不用解,因为有相应的气球 如果全部说谎,则高分获胜 */ void Judge(int a, int b, int p) { if(aTrue)//如果a说的实话,那么就可以直接输出高分获胜 return ; if(a == 1 && b == 1)//表明a,b没有公共的因子,那么a, b说的都是实话,那么质疑被否决,返回 { aTrue = true; return ; } if(b == 1)//到此无法判断a是否是说的实话,但是b说的实话,继续向下判断a bTrue = true; while(p > 1) { if(a % p == 0)//如此进行下去,就不会有共同的公因子 Judge(a/p, b, p-1); if(b % p == 0) Judge(a, b/p, p-1); p--; } return ; } int main() { int a, b; while(~scanf("%d %d", &a, &b)) { if(a < b) { a ^= b; b ^= a; a ^= b; } aTrue = false; bTrue = false; Judge(a, b, 100); if(!aTrue && bTrue)//高分说谎,低分说的是实话,则输出低分 printf("%d ", b); else printf("%d ", a); } return 0; }
原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9134898.html