hdu-A+B问题,大数加法

格式问题很头疼啊

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2 1
2 112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3
Case2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
 int N;
 int count=1;
 scanf("%d",&N);
 getchar();
 char str1[1001],str2[1001];定义两个数组
 while(N--)
 {
  int i=0;
  int lenmax;
  int a[1001]={0},b[1001]={0},c[1001]={0};
  scanf("%s",str1);
  int len1=strlen(str1);
  for(i=0;i<len1;i++)
  {
   a[i]=str1[len1-1-i]-'0';
  }
  scanf("%s",str2);
  int len2=strlen(str2);
  for( i=0;i<len2;i++)
  {
   b[i]=str2[len2-1-i]-'0';
  }
  if(len1>=len2)
    lenmax=len1;
  else
    lenmax=len2;
  int k=0;
  for( i=0;i<lenmax;i++)
  {
   c[i]=(a[i]+b[i]+k)%10;
   k=(a[i]+b[i]+k)/10;
  }
  if(k!=0)
  {
   c[lenmax]=1;
  }
  int n=1;
  printf("Case %d: ",count);
  count++;
  printf("%s + %s = ",str1,str2);
  if(c[lenmax]==1)
  {
   printf("1");
  }
  for( i=lenmax-1;i>=0;i--)
  {
   printf("%d",c[i]);
  }
  printf(" ");
  if(N>=1)
   printf(" ");
   
   
 }
 return 0;
}

原文地址:https://www.cnblogs.com/yfz1552800131/p/5326646.html