PAT Broken Keyboard (20)

题目描写叙述

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters 

corresponding to those keys will not appear on screen.



Now given a string that you are supposed to type, and the string that you actually type out, please list those keys 

which are for sure worn out.

输入描写叙述:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains 

no more than 80 characters which are either English letters [A-Z] (case 

insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.


输出描写叙述:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. 

Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

输入样例:

7_This_is_a_test

_hs_s_a_es

输出样例:

7TI


#include<iostream>
#include <cstring>
#include <cstdlib>
#include <string>

using namespace std;

const int MAX=80;


//去掉字符串中反复的字符
void Remove(char* s, int num)
{
	int i,j,l;
	i=j=0;
	for(i=0;i<num;i++)
	{
		for(l=0;l<j;l++)
		{
			if(s[l]==s[i])
				break;
		}
		if(l>=j)
		{
			s[j++]=s[i];
		}
	}
	s[j]='';
}

//找出第1个字符串中,没有在第2个字符串中出现的字符。
void Worn(char* lhs, char* rhs, char* result)
{
	int i,j,k;
	k=0;
	for(i=0;lhs[i]!='';i++)
	{
		for(j=0;rhs[j]!='';j++)
		{
			if(lhs[i]==rhs[j])
				break;
		}
		if(rhs[j]=='')
		{
			result[k++]=lhs[i];
		}
	}
	result[k]='';
}


int main()
{
	int i;
	string n,m;
	char sn[MAX],sm[MAX],sr[MAX];
	while(cin>>n>>m)
	{
		//将输入的字符串1中的小写英文字符转换为大写英文字符
		for(i=0;i<n.length();i++)
		{
			sn[i]=n[i];
			if((sn[i]>=65)&&(sn[i]<=90) || (sn[i]>=97)&&(sn[i]<=122))
				sn[i]=::toupper(sn[i]);
		}
		sn[i]='';
		
		//将输入的字符串2中的小写英文字符转换为大写英文字符
		for(i=0;i<m.length();i++)
		{
			sm[i]=m[i];
			if((sm[i]>=65)&&(sm[i]<=90) || (sm[i]>=97)&&(sm[i]<=122))
				sm[i]=::toupper(sm[i]);
		}
		sm[i]='';

/*
		for(i=0;sn[i]!='';i++)
			cout<<sn[i]<<" ";
		cout<<endl;

		for(i=0;sm[i]!='';i++)
			cout<<sm[i]<<" ";
		cout<<endl;
*/

		
		Remove(sn,n.length());
		Remove(sm,m.length());

		Worn(sn,sm,sr);
		
		for(i=0;sr[i]!='';i++)
			cout<<sr[i];
		cout<<endl;
	}
	return 0;
}

原文地址:https://www.cnblogs.com/yfceshi/p/6898315.html