非常可乐

题目描述:

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升(正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

输入:

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

输出:

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

样例输入:
7 4 3
4 1 3
0 0 0
样例输出:
NO
3
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
struct node{
    int a,b,c,t;
};
queue<node> q;
int mark[101][101][101];

void atob(int &a,int sa,int &b,int sb){
    if (sb-b>=a){
        b+=a;
        a=0;
    }
    else {
        a = a-(sb-b);
        b=sb;
    }

}

int BFS(int s,int n,int m){//广搜传递的是终点,起点信息在main函数里面加到队列里面 
    
    while(!q.empty()){
        node tt=q.front();
        q.pop();
        
        node temp[6];
        for (int i=0;i<6;i++){
            temp[i]=tt;
        } 
        atob(temp[0].a,s,temp[0].b,n);
        atob(temp[1].b,n,temp[1].a,s);
        atob(temp[2].a,s,temp[2].c,m);
        atob(temp[3].c,m,temp[3].a,s);
        atob(temp[4].b,n,temp[4].c,m);
        atob(temp[5].c,m,temp[5].b,n);
        for (int i=0;i<6;i++){
            if (mark[temp[i].a][temp[i].b][temp[i].c] == false){
                mark[temp[i].a][temp[i].b][temp[i].c] = true;
                node np;
                temp[i].t++;
                int oo= temp[i].a==s/2?1:0;
                int  pp = temp[i].b==s/2?1:0;
                int qq = temp[i].c==s/2?1:0;
                if (oo+pp+qq == 2)
                return temp[i].t;
                q.push(temp[i]);
                
            }
        }
    }
    return -1;
}


int main (){
    int s,n,m;
    while (cin>>s>>n>>m && !(s==0&&m==0&&n==0)){
        if (s%2==1){//奇数肯定不行?? 
            cout<<"NO"<<endl;
            continue;
        }
        for (int i=0;i<=s;i++)
        for (int j=0;j<=n;j++)
        for (int k=0;k<=m;k++)
        mark[i][j][k]=false;  
        
        while (!q.empty()) q.pop();
        mark[s][0][0]=true;
        node temp;
        temp.t=temp.b=temp.c=0;
        temp.a=s;
        q.push(temp);
        int ans;
        ans=BFS(s,n,m);
        if (ans==-1)
        cout<<"NO"<<endl;
        else cout<<ans<<endl;
    }
    return 0;

}

很棒,我根本没想到会是广搜啊。

这种自己的脑子可能做不出,感觉没规律的要穷举的自己试的搜索问题,需要通过广搜,毕竟这是搜索问题啊。

搜索问题!!

还写了一个a倒进b的函数,很有意思。以后要在看。

原文地址:https://www.cnblogs.com/yexiaoqi/p/7238988.html