1.1.8 A+B for InputOutput Practice (VIII) 33.43%(3182,9517)

Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
 
Sample Output
10

15

6
 
Author
lcy
 
 
Recommend
JGShining
#include<iostream>
using namespace std;
int main()
{
int a,s,m,n;
cin>>m;
while(m){
cin>>n;
s=0;
while(n){
cin>>a;
s+=a;
n--;
}
if(m==1)
cout<<s<<endl;
else
cout<<s<<endl<<endl;
m--;
}
return 0;
}



原文地址:https://www.cnblogs.com/yangshuo/p/2357732.html