Restoring Road Network Floyd

问题 C: Restoring Road Network

时间限制: 1 Sec  内存限制: 128 MB
提交: 731  解决: 149
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

样例输入

3
0 1 3
1 0 2
3 2 0

样例输出

3

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

[提交][状态]

题意:给出一个N * N的邻接矩阵,判断这个矩阵是否是跑过floyd的,即任意两点都不可以被松弛,如果可以松弛,输出-1,否则求所有路径唯一(只能直接到达)的两点之间的距离和

#include <bits/stdc++.h>
typedef long long ll;
using namespace std;
ll g[305][305];
int main()
{
    int n;
    cin>>n;
    ll ans=0;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)cin>>g[i][j];
    for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
        {
            bool flag=true;
            for(int k=1;k<=n;k++)
            {
                if(g[i][j]>g[i][k]+g[k][j])
                {
                    cout<<-1<<endl;
                    return 0;
                }
                if(i!=k&&j!=k&&g[i][j]==g[i][k]+g[k][j])flag=false;//两点之间路径不唯一的不计入ans
            }
            if(flag)ans+=g[i][j];
        }
    cout<<ans<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/xusirui/p/9396246.html