POJ 2566 Bound Found 尺取 难度:1

Bound Found
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 1651   Accepted: 544   Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

思路:sum[i][j]=sum[0][j]-sum[0][i-1],所以可以把部分和问题转换成求两个和之间的差最接近T的问题
但是差可能有负也有正,那就把和排序一遍,这样就只能得到非负数差,可以用尺取,记录下编号小的在前就行了
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=100005;
int n,k,T;
typedef pair<long long ,int> P;
P  sum[maxn];int nsts,nste;
long long nstt;
long long calc(int s,int e){
    return sum[e].first-sum[s].first;
}
int main(){
    while(scanf("%d%d",&n,&k)==2&&n&&k){
        long long s=0;
        sum[0].first=0;
        sum[0].second=0;//这个不能在结果中出现,为了使得0存在而加入,是不含元素的和
        for(int i=1;i<=n;i++){
            int tmp;
            scanf("%d",&tmp);
            s+=tmp;
            sum[i].first=s;
            sum[i].second=i;
        }
        nsts=nste=1;nstt=sum[1].first;
        sort(sum,sum+n+1);
        for(int i=0;i<k;i++){
                int l=0,r=1;
                scanf("%d",&T);
                while(l<r&&r<=n){
                        long long tmp=calc(l,r);
                        if(abs(tmp-T)<abs(nstt-T)){
                                nstt=tmp;
                                nsts=min(sum[l].second,sum[r].second)+1;
                                nste=max(sum[l].second,sum[r].second);
                    }
                    if(tmp>T&&l<r-1){
                        l++;
                    }
                    else {
                        r++;
                    }
                }
                printf("%I64d %d %d\n",nstt,nsts,nste);
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/xuesu/p/3975675.html