Program B 暴力求解

      Given a sequence of integers S = {S1,S2,...,Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.


      Input Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

  Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

  Sample Input
    3 2 4 -3
    5 2 5 -1 2 -1
  Sample Output
    Case #1: The maximum product is 8.
    Case #2: The maximum product is 20.

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
	int n;
	int kase=1;
	while(scanf("%d",&n)==1&&n)
	{
		int a[20];
		for(int i=0;i<n;i++)
			scanf("%d",a+i);
		long long sum=1;
		long long m=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i;j<n;j++)
				{
					sum=1;
					for(int k=i;k<=j;k++)
						sum=a[k]*sum;
					m=max(m,sum);
				}
		}
		printf("Case #%d: The maximum product is %lld.

",kase++,m);
	}
	return 0;
}
原文地址:https://www.cnblogs.com/xl1164191281/p/4696705.html