【ACM】hdu_zs3_1003_绝对值排序_201308100742

绝对值排序
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 39   Accepted Submission(s) : 28
Problem Description
输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
 

Input
输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output
对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
 

Sample Input
3 3 -4 24 0 1 2 -30

Sample Output
-4 3 2-3 2 1 0

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>

int cmp(const void *a,const void *b)
{
    return abs(*(int *)b) - abs(*(int *)a);
}
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int i;
        int a[110];
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        qsort(a,n,sizeof(a[0]),cmp);
        for(i=0;i<n;i++)
        {
            if(i<n-1)
            printf("%d ",a[i]);
            else
            printf("%d ",a[i]);
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/xl1027515989/p/3253724.html