【ACM】poj_3981_字符串替换_201307271019

字符串替换
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 8447  Accepted: 3988

Description

编写一个C程序实现将字符串中的所有"you"替换成"we"
Input

输入包含多行数据

每行数据是一个字符串,长度不超过1000
数据以EOF结束
Output

对于输入的每一行,输出替换后的字符串
Sample Input

you are what you do
Sample Output

we are what we do

#include <stdio.h>
#include <string.h>
int main()
{
 char str[1010];
 while(gets(str))
 {
  int i;
  for(i=0;i<strlen(str);i++)
  {
   if(str[i]=='y'&&str[i+1]=='o'&&str[i+2]=='u')
   {
    printf("we");
    i+=2;
   }
   else
   printf("%c",str[i]);
  }
  printf(" ");
 }
 return 0;
}

原文地址:https://www.cnblogs.com/xl1027515989/p/3219120.html