hdu 1003 dp最大子序列和

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 269878    Accepted Submission(s): 64147


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4
 
Case 2:
7 1 6
题目求最大子序列和dp,刚学发现自己写很烂,和大佬有很大差距,贴一个大佬的博客,有完全解析:https://www.cnblogs.com/tommychok/p/5199668.html
自己还需要努力
代码:
#include<iostream>
using namespace std;

int a[100010],dp[100010];//dp[i]表示以a[i]为结尾的子序列的和的最大值 
int main()
{
    int test,k=1;
    cin>>test;
    while(test--)
    {
        int n,sum=0,b,e=1,max; 
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i];
        dp[1]=a[1];//初始化dp[1]这个很重要 
        for(int i=2;i<=n;i++)
        {
            if(dp[i-1]<0)//以a[i-1]为结尾的子序列的和已经为负数 
                dp[i]=a[i];//则a[i]>dp[i-1]+a[i]所以直接把a[i]赋给dp[i] 
            else 
                dp[i]=dp[i-1]+a[i];//dp[i-1]为正数 
        }
        max=dp[1];
        for(int i=2;i<=n;i++)//循环遍历求最大dp 
        {
            if(max<dp[i])
            { 
                max=dp[i];
                e=i;//终点 
            } 
        } 
        b=e;
        for(int i=e;i>0;i--)//从终点开始加和为max是i则为起点 
        {
            sum=sum+a[i];
            if(sum==max)    
                b=i;
        }
        cout<<"Case "<<k++<<":"<<endl<<max<<" "<<b<<" "<<e<<endl;
        if(test) 
            cout<<endl;
        }
     return 0;
}
原文地址:https://www.cnblogs.com/xiongtao/p/8335240.html