ACM 最少步数

最少步数

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
 
描述

这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

 
输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11
#include <iostream>
#include <vector>
#include <cstring>
#include <utility>
#include <queue>
using namespace std;
typedef pair<int,int> Point;

const int maze[9][9] ={
 1,1,1,1,1,1,1,1,1,
 1,0,0,1,0,0,1,0,1,
 1,0,0,1,1,0,0,0,1,
 1,0,1,0,1,1,0,1,1,
 1,0,0,0,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,0,0,0,1,
 1,1,1,1,1,1,1,1,1,
};
bool visit[9][9];
const int dx[] = {0,1,0,-1};
const int dy[] = {1,0,-1,0};

int bfs(Point startP,Point endP){
    queue<Point> p;
    p.push(startP);
    visit[startP.first][startP.second] = true;
    int res = 0,cnt = 0,newCnt = 1;
    while(!p.empty()){
        cnt = newCnt;
        newCnt = 0;
        while(cnt--){
            Point tmp = p.front(); p.pop();
            if(tmp.first == endP.first && tmp.second == endP.second) return res;
            else{
                for(int i = 0; i < 4; ++ i){
                    int newx = tmp.first + dx[i], newy = tmp.second + dy[i];
                    if(!visit[newx][newy] && !maze[newx][newy]){
                        p.push(Point(newx,newy));
                        visit[newx][newy] = true;
                        newCnt++;
                    }
                }
            }
        }
        ++res;
    }
    return -1;
}

int main(){
    int n;
    cin >> n;
    while(n--){
        int a,b,c,d;
        cin >> a >> b >> c >> d;
        memset(visit,false,sizeof(visit));
        cout<<bfs(Point(a,b),Point(c,d))<<endl;

    }
}
原文地址:https://www.cnblogs.com/xiongqiangcs/p/3700911.html