1004. 成绩排名 (20)

1004. 成绩排名 (20)

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

struct student
{
    string name;
    string number;
    int score;
};

bool cmp(student a ,student b)
{
    return a.score>b.score;
}

int main(void)
{
    vector<student> res;
    int n;
    cin>>n;
    while(n--)
    {
        student tmp;
        cin>>tmp.name>>tmp.number>>tmp.score;
        res.push_back(tmp);
    }
    sort(res.begin(),res.end(),cmp);
    vector<student>::iterator it = res.begin();
    vector<student>::iterator it1 = res.end()-1;
    cout<<it->name<<" "<<it->number<<endl;
    cout<<it1->name<<" "<<it1->number<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6367903.html