省赛热身赛之Median

原题:

Description

A median is described as the numeric value separating the higher half of a list, from the lower half. The median of a finite list of numbers can be found by arranging all the elements from lowest value to highest value and picking the middle one. If there is an even number of elements, the median is then defined to be the mean of the two middle values. Now, could you write a program to help to find the median?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

The first line of each test is an integer 0 < n < 500 indicating the number of elements. The second line consists of n numbers, the elements of the list, whose absolute values are smaller than 1,000,000.

Output

For each test case, output the median, with 3 decimal digits.

Sample Input

3
1
0.0
4
1.0 1000.3 100.2 10.1
5
2.0 3.0 5.0 7.0 11.0

Sample Output

0.000
55.150
5.000

分析:

就是按照数学法则求中位数!!!水题~~~~~~~

原码:

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
    int t,n;
    double a[600];
    int s,s1;
    while(scanf("%d",&n)!=EOF)
    {
        while(n--)
        {
            scanf("%d",&t);
            for(int i=0; i<t; i++)
            {
                scanf("%lf",&a[i]);
            }
            sort(a,a+t);
            if(t%2==1)
            {
                s=(t-1)/2;
                printf("%.3f\n",a[s]);
            }
            else if(t%2==0)
            {
                s=(t/2);
                s1=(t/2)-1;
                double y=(a[s]+a[s1])/2;
                printf("%.3f\n",y);
            }
        }
    }
    return 0;
}


 

原文地址:https://www.cnblogs.com/xinyuyuanm/p/2980764.html