ACM田胫赛马

Description

Here is a famous story in Chinese history. 

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others." 

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser." 

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian." 

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match." 

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?" 



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching... 

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem. 

In this problem, you are asked to write a program to solve this special case of matching problem. 
 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case. 
 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars. 
 

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
 

Sample Output

200
0
0
 
解题思路:
题目大意就不用说了就是著名的田胫赛马的故事。输入包括多组案例,第一行输入一个数据,就是每人有几匹马,第二行输入田胫的马的速度,第三行输入 国王的马的速度。其中的输入以输入0为结束。
贪心策略:

 1.当田忌最快的马比齐王最快的马快时,用田忌最快的  马赢齐王最快的马

2.当田忌最快的马比齐王最快的马慢时,用田忌最慢的  马输给齐王最快的马

3.当田忌最快的马跟齐王最快的马一样快时,分情况讨论:

    a.当田忌最慢的马比齐王慢快的马快时,用田忌最慢的  马赢齐王最慢的马

    b.当田忌最慢的马比齐王最慢的马慢时,用田忌最慢的  马输给齐王最快的马

    c.当田忌最慢的马跟齐王最慢的马一样慢时,用田忌最  慢的马与齐王最快的马比

程序代码:

#include <iostream>
#include <algorithm>
using namespace std;
int a[1005],b[1005];
bool fun(int a,int b)
{
    return a>b;
}
int main()
{
    int n;
    while(cin>>n&&n)
    {
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int j=0;j<n;j++)
            cin>>b[j];
        sort(a,a+n,fun);//按从小到大排序
        sort(b,b+n,fun);//按从小到大排序
        int a1=0,a2=n-1,b1=0,b2=n-1,v=0;
        for(int k=0;k<n;k++)
        {
            if(a[a1]>b[b1])//田的最大的马大于王的最大的马时,就让两者比较
            {
                v=v+200;
                a1++;
                b1++;
            }
            else
            {
                if(a[a1]<b[b1])//田的最大的马小于王的最大的马时,用田的最小的马去消耗王最大的马
                {
                    v=v-200;
                    a2--;
                    b1++;
                }
                else//田的最大的马等于王的最大的马时,分情况考虑两人最小的马
                {
                    if(a[a2]>b[b2])//田的最小的马大于王的最小的马时,就让两者比较
                    {
                        v=v+200;
                        a2--;
                        b2--;
                    }
                    else//当田的最小的马小于等于王的最小的马时,就让田的最小的马去消耗王的最大的马
                    {
                        if(a[a2]<b[b1])//当田的最小的马小于王的最大的马时,就减去200。当两者相等时就既不加也不减。当然是不可能大于的。。
                            v=v-200;
                        a2--;
                        b1++;
                    }
                }
            }
        }
        cout<<v<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/xinxiangqing/p/4718113.html