ACM已知面积求最小周长

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper. 
Tleq 10,nleq {10}^{9}
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

3
2
7
12
 

Sample Output

6
16
14
解题思路:
题目的大意就是给定一个矩形的面积要我们求出这个矩形的最小周长。
我们知道一个矩形的最大周长是这样产生的,就是当它的一条边等于面积的大小时,另一条边是1.题目中要求长和宽都要是整数,所以我们要求的就是面积的因子的乘机的最小值。
程序代码:
#include <iostream>
using namespace std;
int main()
{
    int T,j;
    int x;
    cin>>T;
    while(T--)
    {
        cin>>x;
        int min=(1+x)*2,t;
        for(int k=2;k*k<=x;k++)
        {
            if(x%k==0)
            {
                j=x/k;
                  t=2*j+2*k;
                if(t<min)
                 min=t;
            }

        }
        cout<<min<<endl;
    }
    return 0;
}
 
原文地址:https://www.cnblogs.com/xinxiangqing/p/4693035.html