sicily 1443 队列基本操作

1443. Printer Queue

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.

  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).

In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:

  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

//结构图Paper用于存放原始的输入的每个paper的优先级和位置,不进行排序,实际进行操作 
typedef struct paper {
	int priority;
	int position;
} Paper; 

bool cmp (int a, int b) {
	return a > b;
}

int main() {
	int cases;
	cin >> cases;
	
	while (cases-- > 0) {
		int number;
		int target_p;
		int minute = 0;
		vector<int> papers; //根据优先级进行排序产生的降序优先级队列 
		vector<Paper> o_papers; //存放原始的输入的每个paper的优先级和位置,不进行排序,实际模拟打印机操作 
		int paper;
		
		cin >> number >> target_p;
		
		for (int i = 0; i < number; i++) {
			cin >> paper;
			papers.push_back(paper);
			
			Paper temp;
			temp.priority = paper;
			temp.position = i;
			o_papers.push_back(temp); 
		}
		
		sort(papers.begin(), papers.end(), cmp);

		for (int i = 0; i < papers.size(); i++) {
			//根据优先级由高到低的顺序打印 
			while (o_papers[0].priority != papers[i]) {//寻找优先级最高的paper 
				o_papers.push_back(o_papers[0]);
				o_papers.erase(o_papers.begin());
			}
			//找到之后 
			if (o_papers[0].position == target_p) {//是目标paper退出循环 
				minute++;
				break;
			} else {//不是目标paper,从o_papers队列中删除,即进行了打印操作 
				minute++;
				o_papers.erase(o_papers.begin());
			}	
		}
		cout << minute << endl;
	}
	return 0; 
}

  

原文地址:https://www.cnblogs.com/xieyizun-sysu-programmer/p/4005514.html