sicily 1007 to and from 密文解码 数组与下标

1007. To and Fro

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x' to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

#include <iostream>
using namespace std;

//生成密文用,此处无用 
void filter(string &str) {
	string temp;
	for (int i = 0; i < str.length(); i++) {
		if (str[i] >= 97 && str[i] <= 122) {
			temp += str[i];
		} else if (str[i] >= 65 && str[i] <= 90) {
			temp += (str[i] + 32);
		}
	}
	str = temp;
} 

int main() {
	int n;
	string str;
	int col_capacity; 
	
	while (cin >> n && n) {
		
		string sub_str[n]; //存放密文分解出来的字符串,一共n列 
		cin >> str;
		
		//确定每列的字符数 
		if (str.length() % n != 0) {
			col_capacity = str.length() / n + 1; 	
			
		} else {
			col_capacity = str.length() / n;
		}
		
		int k = 0; //用于遍历密文
		 
		for (int i = 0; i < col_capacity; i++) { //依次填充每列从上到下的字符,构成一行 
		 
			if (i % 2 == 0) { // 偶数行则从左到右填充 
				for (int j = 0; j < n; j++)
					sub_str[j].push_back(str[k++]);
			} else { //奇数行则从右到左填充 
				for (int j = n-1; j >= 0; j--) {
					sub_str[j].push_back(str[k++]);
				}
			}
		}
		//依次输出各列即得到明文 
		for (int i = 0; i < n; i++) {
			cout << sub_str[i];
		}
		cout << endl;
	}
	return 0;
} 

  

原文地址:https://www.cnblogs.com/xieyizun-sysu-programmer/p/4004996.html