String Subtraction

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

 

Input Specification:

 

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

 

Output Specification:

 

For each test case, print S1 - S2 in one line.

 

Sample Input:

They are students.

aeiou

Sample Output:

Thy r stdnts.



//主要是时限,所以该想办法用Hash。

 

#include <iostream>

#include <string>

#include <map>

using namespace std;

 

int main()

{

 

      string ss1,ss2;

    int i;

      while(getline(cin,ss1))

      {

 

         getline(cin,ss2);

      

         map<char,bool> mm;

 

         for(i=0;i<ss1.length();i++)

            mm[ss1[i]]=true;

 

         for(i=0;i<ss2.length();i++)

            mm[ss2[i]]=false;

 

         for(i=0;i<ss1.length();i++)

               if(mm[ss1[i]])

                    cout<<ss1[i];

 

               cout<<endl;

      }

 

  return 0;

}

 

 



原文地址:https://www.cnblogs.com/xiaoyesoso/p/4234439.html