poj 1163 数塔

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5 7 3 8 8 1 0  2 7 4 4 4 5 2 6 5

Sample Output

30
题意:
    给定一组三角形形状的数,求出从顶端到底端依次连续相加的最大值。
 
    可以直接将过程中的计算结果保存在当前数组中。这样便可以确保循环中的每次计算都能得到当前位置的最大值。从底至顶的依次推出每个位置的最大值,最后的max[0][0]便是所求。
代码:
#include<iostream>
using namespace std ;
int a[101][101] ;
int b[101][101] ;
int main(){
    int n, t, max = 0 ;
    cin >> n ;
    for(int i=0; i<n; i++)
        for(int j=0; j<=i; j++)
            cin >> a[i][j] ;
    for(int i=n-2; i>=0; i--){
        for(int j=0; j<=i; j++){
            a[i][j] += a[i+1][j]>a[i+1][j+1]?a[i+1][j]:a[i+1][j+1] ;
        }
    }
    cout << a[0][0] << endl ;
}
原文地址:https://www.cnblogs.com/xiaolongchase/p/2137831.html