B

ZOJ Problem Set - 3706

Break Standard Weight
Time Limit: 2 Seconds      Memory Limit: 65536 KB
The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.


With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.


In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.


Input


There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100


Output


For each test case, output the maximum number of possible special masses.


Sample Input


2
4 9
10 10
Sample Output


13
9

题意:

大体意思就是给俩称托 可以把其中一个分成俩,然后求仨秤砣所能测量的最多重量数!

思路:

因为最大为20,所以可以进行枚举,将可能的三个数组成的16种情况用一个数组存放起来,然后用一个三维数组来存放可能组成的数的(无重复的)个数!

细节:

细节处理,别忘了其中一个数为1时,则没法在对其进行分!只需要分另一个数即可!

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int aa[101][101][101]={0};
    int bb[17]={0};
    int x,y,t,i,a,b,c,num=0;
    for(a=0;a<=100;a++)
    for(b=0;b<=100;b++)
    for(c=0;c<=100;c++)
    {
        bb[1]=a; bb[2]=b; bb[3]=c;
        bb[4]=a+b; bb[5]=a+c; bb[6]=b+c;
        bb[7]=a+b+c; bb[8]=fabs(a-c); bb[9]=fabs(b-c); bb[10]=fabs(a-b);
        bb[11]=fabs(a-(b+c)); bb[12]=fabs(a-fabs(b-c)); bb[13]=fabs(b-(a+c));
        bb[14]=fabs(b-fabs(a-c)); bb[15]=fabs(c-(a+b)); bb[16]=fabs(c-fabs(a-c));
        sort(bb+1,bb+17);
        num=0; 
        for(int r=1;r<=16;r++)
        {
            if(bb[r]!=bb[r-1]) num++;
        }
        aa[a][b][c]=num;
    }
    cin>>t;
    while(t--)
    {
        cin>>x>>y;
        int max=0;
        if(x==1) 
        {
            max=aa[1][0][y];
        }
        for(i=1;i<=x/2;i++)
        {
            a=i;b=x-i;
            if(max<aa[a][b][y]) max=aa[a][b][y];
        }
        if(y==1)
        {
            if(max<aa[1][0][x]) max=aa[1][0][x];
        }
        for(i=1;i<=y/2;i++)
        {
            a=i;b=y-i;
            if(max<aa[a][b][x]) max=aa[a][b][x];
        }
        cout<<max<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/xiaolitongxueyaoshangjin/p/13393768.html