hdu5371 最长回文子串变形(Manacher算法)

http://acm.hdu.edu.cn/showproblem.php?

pid=5371

Problem Description
Hotaru Ichijou recently is addicated to math problems. Now she is playing with N-sequence.
Let's define N-sequence, which is composed with three parts and satisfied with the following condition:
1. the first part is the same as the thrid part,
2. the first part and the second part are symmetrical.
for example, the sequence 2,3,4,4,3,2,2,3,4 is a N-sequence, which the first part 2,3,4 is the same as the thrid part 2,3,4, the first part 2,3,4 and the second part 4,3,2 are symmetrical.

Give you n positive intergers, your task is to find the largest continuous sub-sequence, which is N-sequence.
 

Input
There are multiple test cases. The first line of input contains an integer T(T<=20), indicating the number of test cases. 

For each test case:

the first line of input contains a positive integer N(1<=N<=100000), the length of a given sequence

the second line includes N non-negative integers ,each interger is no larger than 109 , descripting a sequence.
 

Output
Each case contains only one line. Each line should start with “Case #i: ”,with i implying the case number, followed by a integer, the largest length of N-sequence.

We guarantee that the sum of all answers is less than 800000.
 

Sample Input
1 10 2 3 4 4 3 2 2 3 4 4
 

Sample Output
Case #1: 9

/**
hdu5371 最长回文子串变形(Manacher算法)
题目大意:找出一个字符串能够均分为三段,第一段和第三段同样。和第二段互为回文串
解题思路:利用Manacher算出每一个位置的最长回文子串的长度,然后枚举就可以
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=210001;
int s[maxn],a[maxn];
int r[maxn],len;

void Manancher()
{
    int l=0;
    a[l++]=-2;
    a[l++]=-1;
    for(int i=0;i<len;i++)
    {
        a[l++]=s[i];
        a[l++]=-1;
    }
    a[l]=-3;
    int mx=0,id=0;
    for(int i=0;i<l;i++)
    {
        r[i]=mx>i?

min(r[2*id-i],mx-i):1; while(a[i+r[i]]==a[i-r[i]])r[i]++; if(i+r[i]>mx) { mx=i+r[i]; id=i; } //printf("%d ",r[i]); } // printf(" "); } int main() { int T,tt=0; scanf("%d",&T); while(T--) { scanf("%d",&len); for(int i=0;i<len;i++) { scanf("%d",&s[i]); } Manancher(); int ans=0; for(int i=1;i<=len*2+1;i+=2) { for(int j=i+r[i]-1;j-i>ans;j-=2) { if(j-i+1<=r[j]) { ans=max(ans,j-i); break; } } } printf("Case #%d: %d ",++tt,ans/2*3); } return 0; }



原文地址:https://www.cnblogs.com/wzjhoutai/p/6912172.html