UVa

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive).

Input

The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.

Output

For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).

Sample Input

1 4

1 10

0 0

Sample Output

2 3

题意:求[a, b]之间的完全平方数

思路: 开根号

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int main() {
    int a, b;
    while (cin>>a>>b&&(a||b)) {
        int n=sqrt(a);
        int m=sqrt(b);
        int num=m-n+1;
        if(n*n<a){
            num--;
        }
        cout<<num<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wydxry/p/7245546.html