PAT自测-5 Shuffling Machine

原题连接https://pta.patest.cn/pta/test/17/exam/4/question/264

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the iii-th position is jjj, it means to move the card from position iii to position jjj. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer KKK (≤20le 2020) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S


我的代码如下,哪位有空的大神能帮咱分析下问题在哪吗?我实在找不出错在哪……
#include<stdio.h>
#define N 54
struct ifo_p
{
    char p_name[3];
    int p_ori ;
    int p_res ;
};
struct ifo_p ifo[N]={{"S1"},{"S2"},{"S3"},{"S4"},{"S5"},{"S6"},{"S7"},{"S8"},{"S9"},{"S10"},{"S11"},{"S12"},{"S13"},
                     {"H1"},{"H2"},{"H3"},{"H4"},{"H5"},{"H6"},{"H7"},{"H8"},{"H9"},{"H10"},{"H11"},{"H12"},{"H13"},
                     {"C1"},{"C2"},{"C3"},{"C4"},{"C5"},{"C6"},{"C7"},{"C8"},{"C9"},{"C10"},{"C11"},{"C12"},{"C13"},
                     {"D1"},{"D2"},{"D3"},{"D4"},{"D5"},{"D6"},{"D7"},{"D8"},{"D9"},{"D10"},{"D11"},{"D12"},{"D13"},
                     {"J1"},{"J2"}
                     };
void jh(int *a,struct ifo_p *ifo)
{
    int i,j;
    for(i=0;i<N;i++)
    {
        j=0;
        while (j<N)
        {if (ifo[j].p_ori==i+1)   //第一次调用函数时ifo[j].p_ori(记为牌的属性)
        {ifo[j].p_res=a[i];       //给出各牌的次序   //重新安排牌的次序
            break;}
        else j++;}
    }
    for (i=0;i<N;i++)
   {for (j=0;j<N;j++)
    {
        if (ifo[j].p_ori==i+1){ifo[j].p_ori=a[i];break;}  //更改牌的属性,以备下次使用
    }
   }
}
void print_s(struct ifo_p *ifo)
{
    int i,j;
    for (j=1;j<=N;j++)
    {for (i=0;i<N;i++)
    {
        if(ifo[i].p_res==j)
        {
            printf(j==N ? "%s" : "%s ",ifo[i].p_name);
            break;
        }
    }}
}
int main()
{
    int n,i,a[N];
    scanf("%d",&n);
    for (i=0;i<N;i++){ifo[i].p_ori=i+1;scanf("%d",&a[i]);}

for (i=0;i<n;i++)jh(a,ifo);   //printf("%d",ifo[1].p_ori);
    print_s(ifo);
    return 0;
}
原文地址:https://www.cnblogs.com/wuxiaotianC/p/5722785.html