最小生成树

POJ 1287
B - Networking
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu
Submit Status

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

//prim算法解答
#include<iostream>
using namespace std;
#include<string>
#include<vector>
#include<string.h>
int prim(int graph[][51],int n)
{
    bool vis[51];
    memset(vis, false, sizeof(vis));
    int dis[51];
    for (int i = 1; i <= n; i++)
        dis[i] = 0x7fffffff;
    int sum = 0;
    vis[1] = true;
    dis[1] = 0;
    for (int i = 2; i <=n; i++)
    {
        if (graph[1][i] != -1)
            dis[i] = graph[1][i];
    }
    for (int i = 0; i < n - 1; i++)
    {
        int minFlag = 0,minValue=0x7fffffff;
        for (int j = 1; j <= n; j++)
        {
            if (dis[j] < minValue&&vis[j] == false)
            {
                minFlag = j;
                minValue = dis[j];
            }
        }
        vis[minFlag] = true;
        sum += minValue;
        for (int j = 1; j <= n; j++)
        {
            if (vis[j] == false && dis[j]>graph[minFlag][j] && graph[minFlag][j] != -1)
                dis[j] = graph[minFlag][j];
        }
    }
    return sum;
}
int main()
{
    int graph[51][51];
    int n = 0, m = 0;
    while (cin >> n&&n != 0)
    {
        cin >> m;
        if (m == 0)
        {
            cout << 0 << endl;
            continue;
        }
        for (int i = 1; i <= n; i++)
        {
            for (int j = 1; j <= n; j++)
                graph[i][j] = -1;
        }
        for (int i = 0; i < m; i++)
        {
            int point1, point2, len;
            cin >> point1 >> point2 >> len;
            if (graph[point1][point2] == -1 || (graph[point1][point2] != -1 && graph[point1][point2]>len))
                graph[point1][point2] = graph[point2][point1] = len;
        }
        int ans = prim(graph, n);
        cout << ans << endl;
    }
    return 0;
}
//kruscal
#include<iostream>
using namespace std;
#include<string>
#include<vector>
#include<string.h>
#include<algorithm>

int fa[51];
typedef struct edge
{
	int x;
	int y;
	int len;
	//edge(int _x, int _y, int _len) :x(_x), y(_y), len(_len){}
}edge;
int cmp(edge e1, edge e2)
{
	return e1.len < e2.len;
}
int findFa(int x)
{
	return fa[x] == x ? x : (fa[x] = findFa(fa[x]));
}
void merge(int x, int y)
{
	fa[findFa(x)] = findFa(y);
}
int kruscal(edge edges[],int n,int m)
{
	sort(edges, edges + m,cmp);
	int cnt = 0;
	int sum = 0;
	for (int i = 0; i < m; i++)
	{
		int fax = findFa(edges[i].x);
		int fay = findFa(edges[i].y);
		if (fax != fay)
		{
			cnt++;
			merge(fax, fay);
			sum += edges[i].len;
			if (cnt == n - 1) break;
		}
	}
	return sum;
}
int main()
{
	edge edges[51*51/2+1];
	int n, m;
	while (cin >> n&&n != 0)
	{
		cin >> m;
		if (m == 0)
		{
			cout << 0 << endl;
			continue;
		}
		for (int i = 1; i <= n; i++)
			fa[i] = i;
		for (int i = 0; i < m; i++)
		{
			int point1, point2, len;
			cin >> point1 >> point2 >> len;
			edge tmp;
			tmp.x = point1;
			tmp.y = point2;
			tmp.len = len;
			edges[i] = tmp;
		}
		int ans = kruscal(edges, n,m);
		cout << ans << endl;
	}
	return 0;
}

  

//prim+优先队列写的
#include<iostream>
using namespace std;
#include<string>
#include<string.h>
#include<vector>
#include<algorithm>
#include<queue>
const  int MAXN=51;
const int INF= 0x7fffffff;
int first[MAXN], u[MAXN], v[MAXN], nexxt[MAXN],w[MAXN];
vector< vector<int> > graph;
int valueMap[MAXN][MAXN];
struct node
{
    int x;
    int y;
    node(int _x, int _y) :x(_x), y(_y){}
    bool operator<(const node& n1) const
    {
        return x > n1.x;
    }
};

int prim(int n, int m)
{
    bool done[MAXN];
    int d[MAXN];
    for (int i = 0; i <= n; i++) d[i] = INF;
    memset(done, false, sizeof(done));
    priority_queue<node> q;
    q.push(node(0, 1));
    d[1] = 0;
    int sum = 0;
    while (!q.empty())
    {
        int u = q.top().y;
        q.pop();
        if (done[u]) continue;
        done[u] = true;
        sum += d[u];
        for (int i = 0; i < graph[u].size(); i++)
        {
            int x = graph[u][i];
            if (!done[x] && d[x]>valueMap[u][x])
            {
                d[x] = valueMap[u][x];
                q.push(node(d[x],x));
            }
        }
    }
    return sum;
}
int main()
{
    int n, m;
    while (cin >> n&&n != 0)
    {
        cin >> m;
        if (m == 0)
        {
            cout << 0 << endl;
            continue;
        }
        graph.clear();
        graph.resize(n+1);
        for (int i = 0; i <= n; i++)
        {
            for (int j = 0; j <= n; j++)
                valueMap[i][j] = -1;
        }
        //构造临接矩阵
        for (int i = 0; i < m; i++)
        {
            int point1, point2, len;
            cin >> point1 >> point2 >> len;
            if (valueMap[point1][point2] == -1 || (valueMap[point1][point2]!=-1&&valueMap[point1][point2]>len))
            {
                graph[point1].push_back((point2));
                graph[point2].push_back((point1));
                valueMap[point1][point2] = valueMap[point2][point1] = len;
            }
        }
        int ans=prim(n, m);
        cout << ans << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wuxiangli/p/6019518.html