HDU 6140 Hybrid Crystals

Hybrid Crystals

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 322    Accepted Submission(s): 191


Problem Description
> Kyber crystals, also called the living crystal or simply the kyber, and known as kaiburr crystals in ancient times, were rare, Force-attuned crystals that grew in nature and were found on scattered planets across the galaxy. They were used by the Jedi and the Sith in the construction of their lightsabers. As part of Jedi training, younglings were sent to the Crystal Caves of the ice planet of Ilum to mine crystals in order to construct their own lightsabers. The crystal's mix of unique lustre was called "the water of the kyber" by the Jedi. There were also larger, rarer crystals of great power and that, according to legends, were used at the heart of ancient superweapons by the Sith.
>
> — Wookieepedia

Powerful, the Kyber crystals are. Even more powerful, the Kyber crystals get combined together. Powered by the Kyber crystals, the main weapon of the Death Star is, having the firepower of thousands of Star Destroyers.

Combining Kyber crystals is not an easy task. The combination should have a specific level of energy to be stablized. Your task is to develop a Droid program to combine Kyber crystals.

Each crystal has its level of energy (i-th crystal has an energy level of ai). Each crystal is attuned to a particular side of the force, either the Light or the Dark. Light crystals emit positive energies, while dark crystals emit negative energies. In particular,

* For a light-side crystal of energy level ai, it emits +ai units of energy.
* For a dark-side crystal of energy level ai, it emits ai units of energy.

Surprisingly, there are rare neutral crystals that can be tuned to either dark or light side. Once used, it emits either +ai or ai units of energy, depending on which side it has been tuned to.

Given n crystals' energy levels ai and types bi (1in), bi=N means the i-th crystal is a neutral one, bi=L means a Light one, and bi=D means a Dark one. The Jedi Council asked you to choose some crystals to form a larger hybrid crystal. To make sure it is stable, the final energy level (the sum of the energy emission of all chosen crystals) of the hybrid crystal must be exactly k.

Considering the NP-Hardness of this problem, the Jedi Council puts some additional constraints to the array such that the problem is greatly simplified.

First, the Council puts a special crystal of a1=1,b1=N.

Second, the Council has arranged the other n1 crystals in a way that
aij=1i1aj[bj=N]+j=1i1aj[bi=Lbj=L]+j=1i1aj[bi=Dbj=D](2in).

[cond] evaluates to 1 if cond holds, otherwise it evaluates to 0.

For those who do not have the patience to read the problem statements, the problem asks you to find whether there exists a set S{1,2,,n} and values si for all iS such that

iSaisi=k,


where si=1 if the i-th crystal is a Light one, si=1 if the i-th crystal is a Dark one, and si{1,1} if the i-th crystal is a neutral one.
 
Input
The first line of the input contains an integer T, denoting the number of test cases.

For each test case, the first line contains two integers n (1n103) and k (|k|106). 

The next line contains n integer a1,a2,...,an (0ai103).

The next line contains n character b1,b2,...,bn (bi{L,D,N}).
 
Output
If there exists such a subset, output "yes", otherwise output "no".
 
Sample Input
2 5 9 1 1 2 3 4 N N N N N 6 -10 1 0 1 2 3 1 N L L L L D
 
Sample Output
yes no
 
Source
 
/*
* @Author: lyuc
* @Date:   2017-08-17 16:25:54
* @Last Modified by:   lyuc
* @Last Modified time: 2017-08-17 16:39:10
*/
/*
 题意;有n个晶石,每个有三种属性,L,D,N,如果选了L的你可以+a[i],选D的你可以-a[i]
    如果选了N的加减都可以,问你能不能凑成k

 思路:这道题中的数能组成的数构成了一个连续区间.一开始只有a[1]的时候能够构成 [-1, 1]
    中的所有整数.如果一堆数能够构成 [-a, b]中的所有整数, 这时候来了一个数 x. 如果 x 
    只能取正值的话, 如果有 x<=b, 那么就能够构成 [-a, b+x]的所有整数.如果 x 只能取负
    值, 如果有 x <=y, 那么就能构成 [-a-x, b]的所有整数.如果 x 可正可负, 如果有 x <=≤min(x,y)
    , 那么就能构成 [-a-x, b+x]中的所有整数.

然后题目中那个奇怪的不等式就保证了上面的"如果有"的条件.
*/

#include <bits/stdc++.h>

#define MAXN 1005
#define MAXA 2

using namespace std;

int t;
int n,k;
int a[MAXN];
char str[MAXN][MAXA];
int l,r;

void init(){
    l=0;
    r=0;
}

int main(){
    //freopen("in.txt","r",stdin);
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        init();
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;i++){
            scanf("%s",str[i]);
        }
        for(int i=0;i<n;i++){
            if(str[i][0]=='L'){
                l-=a[i];
            }else if(str[i][0]=='D'){
                r+=a[i];
            }else{
                l-=a[i];
                r+=a[i];
            }
        }
        if(k>0){
            if(k<=r){
                puts("yes");
            }else {
                puts("no");
            }
        }else if(k<0){
            if(k>=l){
                puts("yes");
            }else{
                puts("no");
            }
        }else{
            puts("yes");
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/7384569.html