poj 3484 Showstopper

Showstopper
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2236   Accepted: 662

Description

Data-mining huge data sets can be a painful and long lasting process if we are not aware of tiny patterns existing within those data sets.

One reputable company has recently discovered a tiny bug in their hardware video processing solution and they are trying to create software workaround. To achieve maximum performance they use their chips in pairs and all data objects in memory should have even number of references. Under certain circumstances this rule became violated and exactly one data object is referred by odd number of references. They are ready to launch product and this is the only showstopper they have. They need YOU to help them resolve this critical issue in most efficient way.

Can you help them?

Input

Input file consists from multiple data sets separated by one or more empty lines.

Each data set represents a sequence of 32-bit (positive) integers (references) which are stored in compressed way.

Each line of input set consists from three single space separated 32-bit (positive) integers X Y Z and they represent following sequence of references: X, X+Z, X+2*Z, X+3*Z, …, X+K*Z, …(while (X+K*Z)<=Y).

Your task is to data-mine input data and for each set determine weather data were corrupted, which reference is occurring odd number of times, and count that reference.

Output

For each input data set you should print to standard output new line of text with either “no corruption” (low case) or two integers separated by single space (first one is reference that occurs odd number of times and second one is count of that reference).

Sample Input

1 10 1
2 10 1

1 10 1
1 10 1

1 10 1
4 4 1
1 5 1
6 10 1

Sample Output

1 1
no corruption
4 3

Source

/*
* @Author: Lyucheng
* @Date:   2017-07-29 20:58:28
* @Last Modified by:   Lyucheng
* @Last Modified time: 2017-08-02 09:59:49
*/
/*
 题意:每次给你X,Y,Z表示产品序列 X,X+Z,X+2*Z,X+3*Z,...,X+k*Z(X+K*Z<Y),让你判断哪个产品名出现过的次数不是偶数次

 思路:异或判断哪个出现过奇数次,然后map计数

 错误:上面的思路时间复杂度会炸掉的,这个题连数据范围都没有

 改进:换种思路,看了题解才想到,二分答案,因为之多有一个是奇数个访问的,所以访问次数的前缀和一定从这个数变成奇数
    利用这个性质来二分答案

 注意的点:这个题数据范围不清晰,要用无符号longlong,并且用I64d输入,cout输出,我试了其他的方式都错了,还有读入空
    行要单独处理
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
#include <sstream>

#define MAXN 1024
#define MAXM 1000005
#define MAX 0xffffffff
#define MIN 0
#define ULL unsigned long long
using namespace std;

char str[MAXN];
ULL X[MAXM],Y[MAXM],Z[MAXM];
ULL res;
int n;

inline ULL getsum(ULL m){
    ULL sum=0;
    for(int i=0;i<n;i++){
        if(m>=Y[i]){
            sum+=(Y[i]-X[i])/Z[i]+1;  
        }else if(m>=X[i]){
            sum+=(m-X[i])/Z[i]+1;    
        }
    }
    return sum;
}

inline void init(){
    n=0;
    res=0;
}

int main(){ 
    // freopen("in.txt", "r", stdin);
    // freopen("out.txt", "w", stdout);
    while(gets(str)){
        init();
        if(strlen(str)>=2){//不是空的
            sscanf(str,"%I64d %I64d %I64d",&X[n],&Y[n],&Z[n]);
            res^=( (Y[n]-X[n])/Z[n]+1);
            n++;
        }
        while(gets(str)!=NULL){
            if(strlen(str)>=2){//不是空的
                sscanf(str,"%I64d %I64d %I64d",&X[n],&Y[n],&Z[n]);
                res^=( (Y[n]-X[n])/Z[n]+1);
                n++;
            }else{
                break;
            }
        }//读入完成
        if(n==0){
            continue;
        }
        if(!(res&1)){//如果调用次数本身就是偶数
            cout << "no corruption" << endl;
            continue;
        }
        ULL l=MIN,r=MAX,m;
        while(r-l>0){
            m=(l+r)/2;
            if(getsum(m)%2==MIN){//前缀和是偶数的
                l=m+1;
            }else{//前缀和是奇数的
                r=m;
            }
        }
        cout<<l<<" "<<getsum(l)-getsum(l-1)<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/7272335.html