poj 2236 Wireless Network

Wireless Network
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 28655   Accepted: 11865

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source

/*
* @Author: Lyucheng
* @Date:   2017-07-20 10:55:59
* @Last Modified by:   Lyucheng
* @Last Modified time: 2017-07-20 11:25:56
*/

/*
 题意:有n台电脑坏了,现在需要修复这些电脑,电脑之间的距离如果小于等于d,就能直接联通,也可以通过中间的介质进行间接的
    联通,有两种操作:O x修复x号电脑
                      S x y询问x y是否联通

 思路:询问好实现,将互相连通的电脑加入一个集合就可,每修复一台电脑要加入集合。
*/

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>

#define MAXN 1005
#define MAXM 2
using namespace std;

struct Node{
    int x,y;
}node[MAXN];
int n,d;
char str[MAXM];
int x,y;
bool vis[MAXN];//电脑是否被修复
int bin[MAXN];

bool ok(Node a,Node b){
    if( d*1.0-sqrt( (a.x-b.x)*(a.x-b.x) +  (a.y-b.y)*(a.y-b.y) )>=0 ) return true;
    return false;
}

void init(){
    memset(vis,false,sizeof vis);
}

int findx(int x){
    int cur=x;
    while(x!=bin[x]){
        x=bin[x];
    }
    bin[cur]=x;//路径压缩
    return x;
}

void fix(int x){
    for(int i=1;i<=n;i++){
        if(vis[i]==false||i==x) continue;
        if(ok(node[x],node[i])==true){
            int fx=findx(i);
            bin[fx]=x;//加入集合
        }
    }
}

int main(){ 
    // freopen("in.txt", "r", stdin);
    // freopen("out.txt", "w", stdout);
    init();
    scanf("%d%d",&n,&d);
    for(int i=1;i<=n;i++){
        scanf("%d%d",&node[i].x,&node[i].y);
        bin[i]=i;
    }
    while(scanf("%s",str)!=EOF){
        if(str[0]=='O'){//修复
            scanf("%d",&x);
            vis[x]=true;
            fix(x);
        }else{//查询
            scanf("%d%d",&x,&y);
            int fx=findx(x);
            int fy=findx(y);
            printf(fx==fy?"SUCCESS
":"FAIL
");
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/7210288.html