poj3254 Corn Fields(状压dp)

Description
Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.
Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input
Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint
Number the squares as follows:
1 2 3
4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

这里写代码片
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>

using namespace std;

const int N=13;
const int mod=100000000;
int n,m;
int map[N];
int f[N][201];
int zt[201],tot=0;

void ss(int t,int sum,int z)  //sum:当前状态 
{
    if (t>m)
    {
        zt[++tot]=sum;  //保存所有可能的状态 
        return;
    }
    int i;
    for (i=0;i<=1;i++)
        if (!(z&i))  //1&1=1  判断同一行中是不是不相邻
           ss(t+1,(sum<<1)+i,i); 
}

void doit()
{
    int i,j,k;
    f[0][1]=1;
    for (i=1;i<=n;i++)
        for (j=1;j<=tot;j++) //循环所有状态 
            if (!(map[i]&zt[j]))  //第i行的状态
            for (k=1;k<=tot;k++)  //枚举上一行的状态 
                if (!(zt[k]&zt[j])&&!(map[i-1]&zt[k]))
                    f[i][j]=(f[i][j]+f[i-1][k])%mod;
    int ans=0;
    for (i=1;i<=tot;i++)
        ans+=f[n][i],ans%=mod;
    printf("%d",ans);
    return;
}

int main()
{
    scanf("%d%d",&n,&m);
    for (int i=1;i<=n;i++)
        for (int j=1;j<=m;j++)
        {
            int x;
            scanf("%d",&x);
            if (!x)  //读入的时候我们用1表示不能放牧
               map[i]+=(1<<(j-1));  //状态记录 
        }   
    ss(1,0,0);
    doit();
    return 0;
}
原文地址:https://www.cnblogs.com/wutongtong3117/p/7673157.html