Harmonic Number

http://acm.hust.edu.cn:8080/judge/contest/view.action?cid=8086#problem/D

D - Harmonic Number

Description

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case nu

mber and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

View Code
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
#define M  0.57721566490153286060651209
double b[10000];
int main()
{
    int n,i;
    b[1]=1;
    for (i=2;i<10000;i++)
    {
        b[i]=b[i-1]+1.0/i;
    }
    cin>>n;
    for (i=1;i<=n;i++)
    {
        int m;
        cin>>m;  
        if (m<10000)
        {
            printf("Case %d: %.10lf\n",i,b[m]);        
        }
        else
        {
            double a=log(m)+M+1.0/(2*m);
            printf("Case %d: %.10lf\n",i,a);    
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wujianwei/p/2497276.html