HDU2680 Choose the best route 最短路 分类: ACM 2015-03-18 23:30 37人阅读 评论(0) 收藏

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8224    Accepted Submission(s): 2706


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1


用Floyd怎么做都超时,用Dijstra。

题目说有几个可以选择的开始的点,如果一个一个比较这些点到最终点s的距离肯定会超时。

关键之处来了,要把几个点先汇到一个虚拟的点,这些点到这个虚拟的点的距离都是0,这样就可以一次就算出这些点到终点的最短距离的最小值。


代码:

#include<stdio.h>
#include<iostream>
using namespace std;
#define N 1111
#define INF 0x3f3f3f3f

int a,b,x,n,s,m;
int mat[N][N];
int used[N],d[N];
void dijkstra()
{
    for(int i=0;i<=n;i++)
    {
        used[i]=0;
        d[i]=mat[0][i];
    }
    while(1)
    {
        int v=-1;
        for(int u=0;u<=n;u++)
            if(!used[u]&&(v==-1||d[u]<d[v]))
                v=u;
        if(v==-1)break;
        used[v]=1;
        for(int u=0;u<=n;u++)
            d[u]=min(d[u],d[v]+mat[v][u]);
    }
}

int main()
{
    while(~scanf("%d%d%d",&n,&m,&s))
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
                if(i==j)
                    mat[i][j]=0;
                else
                    mat[i][j]=INF;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&x);
            if(x<mat[a][b])
            mat[a][b]=x;
        }
    int w,ww;
    scanf("%d",&w);
    while(w--)
    {
        scanf("%d",&ww);
        mat[0][ww]=0;
    }
    dijkstra();
    if(d[s]==INF)
        cout<<-1<<endl;
    else
        cout<<d[s]<<endl;
    }
    return 0;
}


这题还有一个搞笑的地方,头文件用<stdio.h>可以,换成<cstdio>就超时了。所以以后都用<stdio.h>放弃,<cstdio>


版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/wmxl/p/4662710.html