HDu 1001 Sum Problem 分类: ACM 2015-06-19 23:38 12人阅读 评论(0) 收藏

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 338086    Accepted Submission(s): 85117


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
1 100
 

Sample Output
1 5050
 

Author
DOOM III
 

Recommend
We have carefully selected several similar problems for you:  1090 1003 1091 1004 1092

这题其实没有想象的那么简单,要注意先除后乘这样不会爆掉,所以还要考虑奇偶,不过还有种办法是用double存,最后强转回int 也可以

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 115


int main()
{
    int n;
    __int64 w;
    while(~scanf("%d",&n))
    {
        if(n%2==0) w=n/2*(n+1);
        else w=(n+1)/2*n;
        printf("%I64d ",w);
    }




    return 0;
}








版权声明:本文为博主原创文章,未经博主允许不得转载。

原文地址:https://www.cnblogs.com/wmxl/p/4662700.html