poj 1015 Jury Compromise(背包变形dp)

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury. 
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties. 
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J 
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution. 
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties. 
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members. 
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next. 
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.). 
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number. 
Output an empty line after each test case.

Sample Input

4 2 
1 2 
2 3 
4 1 
6 2 
0 0 

Sample Output

Jury #1

Best jury has value 6 for prosecution and value 4 for defence:

 2 3

题意:从n个人里面选m个人出来 每个人都有d,p两个值 选出来的m个人保证sum(d)-sum(p)的绝对值 最小

如果有相同的值 则输出sum(d)+sum(p)最大的

思路:我借鉴的是https://blog.csdn.net/ZscDst/article/details/80698624 这个博客的思路 dp[i][j]表示当前状态最大的和 i表示选人的个数 j表示差 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long int
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
int dp[30][1000];
vector<int> path[30][1000];
int sub[1000]; //记录差 
int sum[1000];// 记录和 
int main(){
    ios::sync_with_stdio(false);
    int n,m;
    int w=0;
    while(cin>>n>>m){
        if(n==0&&m==0) break;
        memset(dp,-1,sizeof(dp));
        memset(sum,0,sizeof(sum));
        memset(sub,0,sizeof(sub));
        int pos=m*20;
        for(int i=1;i<=n;i++){
            int d,p;
            cin>>d>>p;
            sub[i]=d-p;
            sum[i]=d+p;
        }
        for(int i=0;i<30;i++)
            for(int j=0;j<1000;j++)
                path[i][j].clear();
        dp[0][pos]=0;
        for(int i=1;i<=n;i++)
            for(int j=m;j>=1;j--)
                for(int k=0;k<=2*pos;k++){
                    if(k-sub[i]<0||k-sub[i]>2*pos) continue; //越界 
                    if(dp[j-1][k-sub[i]]==-1) continue; //不可行方案 
                    if(dp[j][k]<dp[j-1][k-sub[i]]+sum[i]){ 
                        dp[j][k]=dp[j-1][k-sub[i]]+sum[i];
                        path[j][k]=path[j-1][k-sub[i]];
                        path[j][k].push_back(i);
                    }
                }
        int l=0;
        while(dp[m][pos+l]==-1&&dp[m][pos-l]==-1) l++; //找最小差的位置 
        if(dp[m][pos+l]>dp[m][pos-l]) l=l+pos;
        else l=pos-l;
        int lans=(dp[m][l]+l-pos)/2;
        int rans=(dp[m][l]+pos-l)/2;
        cout<<"Jury #"<<++w<<endl;
        cout<<"Best jury has value "<<lans<<" for prosecution and value "<<rans;
        cout<<" for defence:"<<endl;
        for(int i=0;i<m;i++)
            cout<<" "<<path[m][l][i];
        cout<<endl;
    }
    return 0;
}

 

 

原文地址:https://www.cnblogs.com/wmj6/p/10633249.html