poj 3279 Fliptile(二进制搜索)

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4

1 0 0 1

0 1 1 0

0 1 1 0

1 0 0 1

Sample Output

0 0 0 0

1 0 0 1

1 0 0 1

0 0 0 0

题意:有一个n*m的矩形 里面有0/1矩阵 现在需要翻转(每次上下左右中翻转)成全0的矩阵 问最少需要多少次

思路:二进制枚举第一行的所有翻转情况 然后保证1~(m-1)行没有1出现 这样我们只要遍历最后一行 只要没有1就是一种方案

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long int
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dir[5][2]={1,0 ,0,1 ,-1,0 ,0,-1,0,0};
int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
int m,n;
int G[30][30];
int temp[30][30];
int ans[30][30];
int get(int x,int y){ //计算当前位置是否为1 
    int c=G[x][y];
    for(int i=0;i<5;i++){
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx>=1&&xx<=m&&yy>=1&&yy<=n)
            c+=temp[xx][yy];
    }
    return c%2;
}
int solve(){
    for(int i=2;i<=m;i++)
        for(int j=1;j<=n;j++)
            if(get(i-1,j)) //如果上面一个位置是1 就需要翻转当前位置 
                temp[i][j]=1;
    for(int i=1;i<=n;i++)
        if(get(m,i))
            return -inf;
    int cnt=0;
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            if(temp[i][j]) cnt++;
    return cnt;
}
int main(){
    ios::sync_with_stdio(false);
    while(cin>>m>>n){
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                cin>>G[i][j];
        int anss=-inf;
        for(int i=0;i<(1<<n);i++){ //二进制枚举第一行的所有情况 
            memset(temp,0,sizeof(temp));
            for(int j=1;j<=n;j++)
                temp[1][j]=(i>>(j-1))&1;
            int te=solve();
            if(te>anss){
                for(int p=1;p<=m;p++)
                    for(int q=1;q<=n;q++)
                        ans[p][q]=temp[p][q];
                anss=te;
                break;
            }
        }
        if(anss==-inf) cout<<"IMPOSSIBLE"<<endl;
        else{
            for(int i=1;i<=m;i++){
                for(int j=1;j<=n;j++)
                    if(j==1) cout<<ans[i][j];
                    else cout<<" "<<ans[i][j];
                cout<<endl;
            }        
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wmj6/p/10458303.html