poj1088滑雪最短路径

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 97281   Accepted: 36886

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25


dp[i][j] = max(dp[i-1][j], dp[i+1][j], dp[i][j-1], dp[i][j+1]) + 1;
采用记忆化搜索
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 100 + 5;
int R, C;
int h[maxn][maxn];
int d[maxn][maxn];
int dx[4] = {-1, 1, 0, 0};
int dy[4] = {0, 0, -1, 1};

int dp(int x, int y)
{
    int k, maxd = 0, s;
    if (d[x][y] != 0)
        return d[x][y];  //搜索过了就不用搜了
    for (k = 0; k <= 3; k++)
    {
        int tx, ty;
        tx = x + dx[k];
        ty = y + dy[k];
        if (tx < 1 || ty < 1 || tx > R || ty > C)
            continue;
       if (h[x][y] > h[tx][ty]) {
            s = dp(tx, ty);
            maxd = max(maxd, s);
       }
    }
    d[x][y] = maxd+1;

    return d[x][y];
}

int main()
{
    cin >> R >> C;
    int i, j, Max = 0;

    memset(d, 0, sizeof(d));
    for (i = 1; i <= R; i++)
        for (j = 1; j <= C; j++)
            cin >> h[i][j];

    for (i = 1; i <= R; i++) {
        for (j = 1; j <= C; j++) {
            Max = max(Max, dp(i, j));
        }
    }
    cout << Max << endl;

    return 0;
}


 
原文地址:https://www.cnblogs.com/whileskies/p/6917633.html