二叉搜索查找排序树

很早做过的一道OJ题,挺有意思的,刚刚好学到二叉搜索/查找/排序树。

N - Elven Postman

HDU - 5444

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

imgimg

Input

First you are given an integer T(T≤10)T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000)n(n≤1000) on a line representing the number of rooms in this tree. nn integers representing the sequence written at the root follow, respectively a1,…,ana1,…,an where a1,…,an∈{1,…,n}a1,…,an∈{1,…,n}.

On the next line, there is a number qq representing the number of mails to be sent. After that, there will be qq integers x1,…,xqx1,…,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (EE or WW) the postman needs to make to deliver the mail. For that EE means that the postman should move up the eastern branch and WW the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output

E

WE
EEEEE

代码

#include "bits/stdc++.h"
using namespace std;
struct tree{
    int date;//数据域
    tree *left;//指向当前根节点的左节点,left存储该节点的左节点地址,没有对象为NULL
    tree *right;//指向当前根节点的右节点,right存储该节点的右节点地址,没有对象为NULL
    tree(){}
    explicit tree(int x){
        date = x;
        left = right = NULL;
    }
} *root;//root存储该结构体的地址,方便根节点指向.*root 为结构体
tree *join(tree *now_root, int date){
    if (now_root == NULL) {//当前指针没有指向节点,也即,初始跟节点,或者某深度跟节点无分支
        tree *t = new tree;//堆里为对象分配内存,并为这块内存调用构造函数。
        *t = tree(date);
        return t;
    }
    if (date < now_root->date)//比当前节点小,一直往深度搜索,
        now_root->left = join(now_root->left, date);//直到根节点下,指针没有指向,且符合条件
    if (date > now_root->date)//比当前节点大
        now_root->right = join(now_root->right, date);//深度遍历,
    return now_root;//返回指针。
}
void to_find(tree *now_root, int date){
    if (now_root == NULL)//该根节点没有分支,找到尽头
        return;
    if (now_root->date > date){
        cout<<"E";//值大小与当前的根节点对比,传递根节点指向的下一个节点的地址
        to_find(now_root->left, date);//深度搜索
    }
    if (now_root->date < date){
        cout<<"W";
        to_find(now_root->right, date);
    }
}
int main(){
    int t;
    scanf("%d", &t);
    while (t--){
        root = NULL;//意思就是第一个根节点不是谁的左节点或者右节点
        int n, date, m;
        scanf("%d", &n);
        for (int i = 0; i < n; ++i) {
            scanf("%d", &date);
            root = join(root, date);//“root指向的地址都是第一个根节点”然后往深度搜索
        }
        scanf("%d", &m);
        for (int j = 0; j < m; ++j) {
            scanf("%d", &date);
            to_find(root, date);//从根节点开始搜索
            printf(" ");
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wfybeliefs/p/12786946.html