杭电1071-The area

问题描述:
 
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 
Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 
Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
 
Sample Output
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
问题分析:
注意:
          已知抛物线与直线相交两点和抛物线顶点,顶点P1(-b/(2a), (4ac-b^2)/4a)。
          抛物线方程:y=ax^2+bx+c;
          直线方程:y=kx+h;
          已知p1,p2,p3可以求出a,b,c,k,h
          y1=ax1^2+bx1+c
          y2=ax2^2+bx2+c
          y1-y2=(x1-x2)(a(x1+x2)+b)
          又x1=-b/2a,
          所以a=(y2-y1)/(x2-x1)^2
          面积用积分公式化简为:
          S=a/3*(x3^3–x2^3)+(b-k)/2*(x3^2–x2^2)+(c-h)*(x3-x2);
AC代码:
#include <cstdlib>
#include <iostream>
#include<iomanip>
using namespace std;

int main(int argc, char *argv[])
{
    double x1,x2,x3,y1,y2,y3,area;
    double a,b,c,k,h;
    int n;
    cin>>n;
    while(n--)
    {
       cin>>x1>>y1;
       cin>>x2>>y2;
       cin>>x3>>y3;
       a=(y2-y1)/((x2-x1)*(x2-x1));
       b=-2*a*x1;
       c=y1-a*x1*x1-b*x1;
       k=(y3-y2)/(x3-x2);
       h=y3-k*x3;
       area=a/3*(x3*x3*x3-x2*x2*x2)+(b-k)/2*(x3*x3-x2*x2)+(c-h)*(x3-x2);
       cout<<fixed<<setprecision(2)<<area<<endl;
    }
    system("PAUSE");
    return EXIT_SUCCESS;
}

原文地址:https://www.cnblogs.com/wft1990/p/4313644.html