Uva 232 一个换行WA 了四次

由于UVA OJ上没有Wrong anwser,搞的多花了好长时间去测试程序,之前一直以为改OJ有WA,后来网上一搜才知道没有WA,哎哎浪费了好长时间。此博客用来记录自己的粗心大意。

链接地址:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=4&page=show_problem&problem=168

232 - Crossword Answers

Time limit: 3.000 seconds

 Crossword Answers 

A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).

One list of definitions is for ``words" to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.

The definitions correspond to the rectangular grid by means of sequential integers on ``eligible" white squares. White squares with black squares immediately to the left or above them are ``eligible." White squares with no squares either immediately to the left or above are also ``eligible." No other squares are numbered. All of the squares on the first row are numbered.

The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.

An ``across" word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row.

The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.

A ``down" word for a definition is written on a sequence of white squares in a column starting on a numbered square that does not follow another white square in the same column.

The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.

Input

Each puzzle solution in the input starts with a line containing two integers r and c (  and  ), where r (the first number) is the number of rows in the puzzle and c (the second number) is the number of columns.

The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those c characters is an alphabetic character which is part of a word or the character ``*", which indicates a black square.

The end of input is indicated by a line consisting of the single number 0.

Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the list of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number of their corresponding definitions.

The heading for the list of across words is ``Across". The heading for the list of down words is ``Down".

In the case where the lists are empty (all squares in the grid are black), the Across and Down headings should still appear.

Separate output for successive input puzzles by a blank line.

Sample Input

2 2 AT *O 6 7 AIM*DEN *ME*ONE UPON*TO SO*ERIN *SA*OR* IES*DEA 0 Sample Output

puzzle #1:

Across  

   1.AT  

   3.O

Down  

    1.A  

    2.TO

puzzle #2:

Across  

     1.AIM  

     4.DEN  

     7.ME  

     8.ONE  

     9.UPON  

  11.TO  

  12.SO  

  13.ERIN  

  15.SA  

  17.OR  

  18.IES  

  19.DEA

Down  

    1.A  

    2.IMPOSE  

    3.MEO  

    4.DO  

    5.ENTIRE  

    6.NEON  

    9.US  

  10.NE  

  14.ROD  

  16.AS  

  18.I  

  20.A

 源代码如下:

#include<iostream>
#include<string.h>
using namespace std;
#define SIZE 20
#define MAX 200
int main()
{   int pu[SIZE][SIZE];
    char s[SIZE][SIZE];
	char str[MAX][SIZE];
	int r, c;
	int T=0;

    while(cin>>r && r!= 0 )
	{
		int count=1;
		for(int i=0; i<MAX; i++)
		{ 
			  for(int j=0; j<SIZE ; j++)
		                 str[i][j]='\0';
		} 
	   cin>>c;
	   for(int i=0; i<r ; i++)
	   {
	         for(int j=0; j<c ; j++)
		   {      pu[i][j]=0;
		         cin>>s[i][j];

				 if( i==0 )  //diyihang
				 {
				     if(s[i][j] != '*')
					 {
						 pu[i][j]=count;
						 count++;
				     }
					// else s[i][j]=0;
		   
		       }
				 else 
				 {
					 if( j==0  && s[i][j] != '*')
						    {   pu[i][j]=count;
					           count++;
					        }
					 else if(s[i][j-1]=='*' && s[i][j] != '*')
					    {
						        pu[i][j]= count;
								 count++;
					    }
					 else if(s[i-1][j]=='*' && s[i][j] != '*')
					 {
					     pu[i][j]= count;
					       count++;
					 }
					 else ;
				 }
	   
	   }
	   }

	      if(T >0 ) cout<<endl;  //我之前在后面直接cout<<endl,这样便会造成会多输出一空行,造成WA,所以一定要切记!
          T++;
		  cout<<"puzzle #"<<T<<":"<<endl;
		  cout<<"Across"<<endl;
		  for(int i=0; i<r ; i++)
		  {     bool flag = false;
		        int start=1;
				// bool sflag= false;
		     for(int j=0; j<c ; j++)
			 {     
			       if( s[i][j] == '*')
				   {     if(flag)
				       {
				         cout<<endl;
				         flag = false; 
				     }
				   }
				   else 
				   {    if( !flag )  
				             {    
								 start =pu[i][j];
								   if(start <10 )
					                     cout<<"  ";
				                  else cout<<" ";
				               cout<<start<<".";
								   flag = true;
				           }
					     cout<<s[i][j];
						 // flag = true;
					if( j== c-1)		
					{
					   cout<<endl;
					   flag = false;
					}
				   }			 
			 
			 }
		  
		  }
		 // cout<<"Down"<<endl;
		  int locstr=0;
		//   int start=1;
		  for(int j=0; j<c ; j++)
		   {   bool flag = false;
		           
					
					int countstr=0;
		      for(int i=0; i<r ; i++)
			  {
				    
					if( s[i][j] =='*' )
					{
					     if(flag)
				       {
				        // cout<<endl;
				        // flag = false; 
						    str[locstr][countstr]='\0';
								 // locstr++;
								 countstr=0;
								 flag = false;
				     } 

					}
					else
					{
					  if( !flag )  
				             {    
								
								 locstr =pu[i][j];
								
								 flag = true;
								// str[locstr][countstr++]=""
								/* start =pu[i][j];
								   if(start <10 )
					                     cout<<"  ";
				                  else cout<<" ";
				               cout<<start<<".";
								  flag = true;
								  */
				           }
					   //  cout<<s[i][j];
					   str[ locstr][countstr++]=s[i][j];
						 // flag = true;
					if( i== r-1)		
					{
					  // cout<<endl;
					  // flag = false;
						 str[locstr][countstr]='\0';
								//  locstr++;
								 countstr=0;
								  flag = false;
					}

					}

			  }

		  }
		 //  qsort(str,MAX,sizeof(str[0]),comp);
		  cout<<"Down"<<endl;
		  for(int i=0; i<MAX; i++)
		  {
		     int len = strlen(str[i]);
			 if(len >0 )
			 {
			
					   if(i <10 )
					          cout<<"  ";
				        else cout<<" ";
						cout<<i<<".";
						cout<<str[i]<<endl;
				              // cout<<start<<".";
			 
			 }
		  
		  }

	


	  // cout<<endl;
	}


   return 0;
}

作者: 盛夏落木

出处: https://www.cnblogs.com/wanshuafe/

关于作者:专注云存储,文件系统领域,请多多赐教!

本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出, 原文链接 如有问题, 可邮件(wanshuafe@163.com)咨询.

原文地址:https://www.cnblogs.com/wanshuafe/p/4357617.html