1002 A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include<cstdio>
const int maxn = 1010;
double p[maxn] = {};
int main(){
    int k,n;
    double a;
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        scanf("%d %lf",&n,&a);
        p[n] += a;
    }
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        scanf("%d %lf",&n,&a);
        p[n] += a;
    }
    int count = 0;
    for(int i = 0; i < maxn; i++){
        if(p[i] != 0) count++;
    }
    printf("%d",count);
    for(int i = maxn - 1; i >= 0; i--){
        if(p[i] != 0) printf(" %d %.1f",i,p[i]);
    }
    return 0;
}
//数组要放在全局变量里 
#include<cstdio>
#include<string.h>
const int maxn = 1020;
//double arr[maxn] = {0}; 
int main()
{
    int k;
    int total = 0;
    int exp;
    double coe;
    double arr[maxn] = {0};
    //memset(arr,0,sizeof(arr));
    scanf("%d",&k);
    for(int i = 0; i < k; i++)
    {
        scanf("%d%lf",&exp,&coe);
        arr[exp] += coe;
    }
    scanf("%d",&k);
    for(int i = 0; i < k; i++)
    {
        scanf("%d%lf",&exp,&coe);
        arr[exp] += coe;
    }
    for(int i = 0; i < maxn; i++)
    {
        if(arr[i])
        {
            total++;
        }
    }
    printf("%d",total);
    for(int i = maxn - 1; i >= 0; i--)
    {
        if(arr[i])
        {
            printf(" %d %.1f",i,arr[i]);
        }
    }
    return 0;
}

总结:如果double定义在全局变量,且初始化为0则全部为0;

  如果定义在main函数中并且初始化,它只会初始化到maxn-1下标个单位为0

原文地址:https://www.cnblogs.com/wanghao-boke/p/9384873.html