04-树5 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of keys to be inserted. Then Ndistinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88
#include<cstdio>
#include<algorithm>
using namespace std;

struct Node{
    int v;
    int height;
    Node* lchild;
    Node* rchild;
}*root;


int getHeight(Node* root);
void updateHeight(Node* root);
int getBalanceFactor(Node* root);
Node* NewNode(int v);
void Insert(Node* &root, int v);
void L(Node* &root);
void R(Node* &root);

int main(){
    int n,v;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d",&v);
        Insert(root,v);
    }
    printf("%d",root->v);
    return 0;
}
void Insert(Node* &root, int v){
    if(root == NULL){
        root = NewNode(v);
        return;
    }
    if(root->v > v){
        Insert(root->lchild,v);
        updateHeight(root);
        if(getBalanceFactor(root) == 2){
            if(getBalanceFactor(root->lchild) == 1){
                R(root);
            }else if(getBalanceFactor(root->lchild) == -1){
                L(root->lchild);
                R(root);
            }
        }
    }else{
        Insert(root->rchild,v);
        updateHeight(root);
        if(getBalanceFactor(root) == -2){
            if(getBalanceFactor(root->rchild) == -1){
                L(root);
            }else if(getBalanceFactor(root->rchild) == 1){
                R(root->rchild);
                L(root);
            }
        }
    }
}

Node* NewNode(int v){
    Node* node = new Node;
    node->v = v;
    node->lchild = node->rchild = NULL;
    node->height = 1;
    return node;
}

void updateHeight(Node* root){
    root->height = max(getHeight(root->lchild),getHeight(root->rchild))+1;
}

int getHeight(Node* root){
    if(root == NULL) return 0;
    return root->height;
}

int getBalanceFactor(Node* root){
    return getHeight(root->lchild) - getHeight(root->rchild);
}

void L(Node* &root){
    Node* temp = root->rchild;
    root->rchild = temp->lchild;
    temp->lchild = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp;
}

void R(Node* &root){
    Node* temp = root->lchild;
    root->lchild = temp->rchild;
    temp->rchild = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp; 
}
原文地址:https://www.cnblogs.com/wanghao-boke/p/10697746.html