1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (105​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7
 
#include<cstdio>
const int maxn = 1000100;
bool arr[maxn] = {false};

int main(){
    int n;
    scanf("%d",&n);
    int num;
    for(int i = 0; i < n; i++){
        scanf("%d",&num);
        if(num > 0 && num < maxn) arr[num] = true;
    }
    for(int i = 1; i < maxn; i++){
        if(arr[i] == false){
            printf("%d",i);
            return 0;
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wanghao-boke/p/10458570.html