深搜例题1

Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

题解如下
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
using namespace std;

int w,h,sx,sy,ans;
char map[21][21];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
bool v[21][21];
int a[410];
void dfs(int x,int y)
{
    
    for(int i=0;i<=3;i++)
    {
        int tx=x+dx[i],ty=y+dy[i];
        if(tx>=1&&tx<=h&&ty>=1&&ty<=w&&map[tx][ty]!='#'&&v[tx][ty]==0)
        {
            ans++;
            v[tx][ty]=1;
            dfs(tx,ty);
        }
    }
}
int main()
{
    while(cin>>w>>h&&w!=0&&h!=0)
    {
        ans=0;
        for(int i=1;i<=h;i++)
               for(int j=1;j<=w;j++)
              {
                  cin>>map[i][j];
                  if(map[i][j]=='@')
                  {
                      sx=i;
                      sy=j;
                  }
              }
        memset(v,0,sizeof(v));
        v[sx][sy]=1;
        dfs(sx,sy);
        cout<<ans+1<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/wanghaixv/p/8484810.html