POJ 1797 Heavy Transportation (Dijkstra算法变形)

Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4
题意:给你n个点和m条边,要求找一条从1到n的路径,使得这个路径上最小的边权最大
分析:
可以把路径的长度看做这条路径上经过的最小边权,然后就是求路径的最大值,可以用Dijkstra的变形
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

const int MAXN = 1100;
const int INF = 0x3f3f3f3f;

int cost[MAXN][MAXN];
int dis[MAXN];
bool vis[MAXN];

void Dijkstra(int n,int st)
{
    for(int i=1;i<=n;i++) dis[i]=0,vis[i]=false;
    dis[st]=INF;
    for(int j=0;j<n;j++){
        int k=-1;
        int Max=0;
        for(int i=1;i<=n;i++)
            if(!vis[i]&&Max<dis[i]){
               Max=dis[i];
               k=i;
            }
        if(k==-1) break;
        vis[k]=true;
        for(int i=1;i<=n;i++)
            if(!vis[i]&&min(dis[k],cost[k][i])>dis[i])
               dis[i]=min(dis[k],cost[k][i]);
    }
}

int main()
{
    int T;
    int n,m;
    int iCase=0;
    scanf("%d",&T);
    while(T--){
        iCase++;
        scanf("%d%d",&n,&m);
        memset(cost,0,sizeof(cost));
        int u,v,w;
        while(m--){
            scanf("%d%d%d",&u,&v,&w);
            cost[u][v]=cost[v][u]=w;
        }
        Dijkstra(n,1);
        printf("Scenario #%d:
%d

",iCase,dis[n]);
    }
    return 0;
}
 
原文地址:https://www.cnblogs.com/wangdongkai/p/5627484.html