Codeforces Round #346 (Div. 2)B. Qualifying Contest

B. Qualifying Contest
time limit per test 
1 second
memory limit per test 
256 megabytes
input 
standard input
output 
standard output
Description

Very soon Berland will hold a School Team Programming Olympiad. From each of the m Berland regions a team of two people is invited to participate in the olympiad. The qualifying contest to form teams was held and it was attended by n Berland students. There were at least two schoolboys participating from each of the m regions of Berland. The result of each of the participants of the qualifying competition is an integer score from 0 to 800 inclusive.

The team of each region is formed from two such members of the qualifying competition of the region, that none of them can be replaced by a schoolboy of the same region, not included in the team and who received a greater number of points. There may be a situation where a team of some region can not be formed uniquely, that is, there is more than one school team that meets the properties described above. In this case, the region needs to undertake an additional contest. The two teams in the region are considered to be different if there is at least one schoolboy who is included in one team and is not included in the other team. It is guaranteed that for each region at least two its representatives participated in the qualifying contest.

Your task is, given the results of the qualifying competition, to identify the team from each region, or to announce that in this region its formation requires additional contests.

Input
The first line of the input contains two integers n and m (2 ≤ n ≤ 100 000, 1 ≤ m ≤ 10 000, n ≥ 2m) — the number of participants of the qualifying contest and the number of regions in Berland.

Next n lines contain the description of the participants of the qualifying contest in the following format: Surname (a string of length from 1to 10 characters and consisting of large and small English letters), region number (integer from 1 to m) and the number of points scored by the participant (integer from 0 to 800, inclusive).

It is guaranteed that all surnames of all the participants are distinct and at least two people participated from each of the m regions. The surnames that only differ in letter cases, should be considered distinct.

Output

Print m lines. On the i-th line print the team of the i-th region — the surnames of the two team members in an arbitrary order, or a single character "?" (without the quotes) if you need to spend further qualifying contests in the region.

Sample input 

5 2
Ivanov 1 763
Andreev 2 800
Petrov 1 595
Sidorov 1 790
Semenov 2 503

Sample output

Sidorov Ivanov
Andreev Semenov

Sample input 

5 2
Ivanov 1 800
Andreev 2 763
Petrov 1 800
Sidorov 1 800
Semenov 2 503

Sample output

?
Andreev Semenov

总结
这道题用到了优先队列,思想是每次取出最大的进行比较。主要是学到了关于优先队列的知识,如怎样构造,使用函数等。

   成员函数:

empty

true if the priority queue has no elements

pop

removes the top element of a priority queue

push

adds an element to the end of the priority queue

size

returns the number of items in the priority queue

top

returns the top element of the priority queue


优先队列对不同类型的使用:
对结构体使用,要进行运算符重载:
 friend bool operator< (T n1, T n2)  
    {  
        return n1.priority < n2.priority;  
    }  

默认是最大的优先级最高,若想反过来元素越小,优先级越高,则需要使用函数对象greater,表明在决定向优先级队列中插入新元素时,push()应该使用的操作符是>而不是<.


priority_queue<int, vector<int>, greater<int> > q; 

于是,这道题代码是

#include<bits/stdc++.h>
using namespace std;
struct a{
     friend bool operator< (a n1, a n2)
    {
        return n1.cap < n2.cap;
    }
   char name[15];
   int cap;
};
priority_queue<a> q[10005];
a b;
int main()
{
    int n,m,k;
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++){
       scanf("%s %d %d",b.name,&k,&b.cap);
       q[k].push(b);
    }
    a t1,t2,t3;
    for(int i=1;i<=m;i++){
        t1=q[i].top();
        q[i].pop();
        t2=q[i].top();
        q[i].pop();
        //cout <<q[i].size();
        if(q[i].size()==0)
            cout <<t1.name<<" "<<t2.name<<endl;
        else {
             t3=q[i].top();
             if(t2.cap>t3.cap){
                  cout <<t1.name<<" "<<t2.name<<endl;
             }
              else cout<<"?"<<endl;
        }
    }
    return 0;
}
 
 
原文地址:https://www.cnblogs.com/wangdongkai/p/5339930.html