HDU_1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40967    Accepted Submission(s): 8785


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 


Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 


Output
For each test case, print the value of f(n) on a single line.
 


Sample Input
1 1 3
1 2 10
0 0 0
 


Sample Output
2
5
 


Author
CHEN, Shunbao
 


Source
 

找到规律,打表就可以了

View Code
#include <stdio.h>
int f[1009];
int main()
{
int a, b, i, n, c;
f[
1] = 1;
f[
2] = 1;
while(scanf("%d%d%d",&a,&b,&n) && (a || b || n))
{
for(i = 3; i < 50;i ++)
{
f[i]
= (a*f[i-1] + b*f[i-2]) % 7;
if(f[i] == 1 && f[i-1] == 1)
break;
}
c
=i-2;
n
=n%c;
if(n == 0)
printf(
"%d\n",f[c]);
else
printf(
"%d\n",f[n]);
}
return 0;
}
原文地址:https://www.cnblogs.com/vongang/p/2115046.html