[ACM] hdu 2602 Bone Collector(01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25042    Accepted Submission(s): 10147


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 


 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 


 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 


 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 


 

Sample Output
14
 


 

Author
Teddy
 


 

Source

解题思路:

纯粹的01背包。

先附上二维数组的解法代码:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

int dp[1002][1002];
int value[1002],w[1002];
int N,V;

int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>N>>V;
        for(int i=1;i<=N;i++)
            cin>>value[i];
        for(int i=1;i<=N;i++)
            cin>>w[i];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++)
            for(int j=0;j<=V;j++)//千万要记得重量要从0开始,不是1
        {
            if(w[i]<=j)
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+value[i]);
            else
                dp[i][j]=dp[i-1][j];
        }
        cout<<dp[N][V]<<endl;
    }
    return 0;
}


 

用一维数组写的代码:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

int dp[1002];
int v[1002];//价值
int w[1002];//容量
int N,V;//骨头个数,最大容量

void solve()//01背包实现
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<N;i++)
        for(int j=V;j>=w[i];j--)
        dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
}

int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>N>>V;
        for(int i=0;i<N;i++)
            cin>>v[i];
        for(int i=0;i<N;i++)
            cin>>w[i];
        solve();
        cout<<dp[V]<<endl;

    }
    return 0;
}


运行:

原文地址:https://www.cnblogs.com/vivider/p/3697691.html