[ACM] hdu 1536 S-Nim(Nim组合博弈 SG函数打表)


S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4004    Accepted Submission(s): 1732

Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.  The players take turns chosing a heap and removing a positive number of beads from it.  The first player not able to make a move, loses.Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).  If the xor-sum is 0, too bad, you will lose.  Otherwise, move such that the xor-sum becomes 0. This is always possible.It is quite easy to convince oneself that this works. Consider these facts:  The player that takes the last bead wins.  After the winning player's last move the xor-sum will be 0.  The xor-sum will change after every move.Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
 

Sample Input
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
LWW WWL


解题思路:

这个题折腾了两三天,参考了两个模板,在这之间折腾过来折腾过去,终于把用法和需要注意的地方弄清楚了,汗。注意的是: bool类型的数组比int类型的数组快,不超时与超时的区别,在sg组合博弈时,只能在(a1,a2,a3,a4)中取,要特别注意这里面的数字是否是有序的,这个特别重要,下面贴出的两个模板对应了两种情况。最后,大数据输入还得用scanf。。

模板1(该模板注意的是一定要把 f 数组中的数字从小到大排序):

const int N=10008;//N为所有堆最多石子的数量
int f[108],sg[N];//f[]用来保存只能拿多少个,sg[]来保存SG值
bool hash[N];//mex{}
void sg_solve(int t,int N)
{
    int i,j;
    memset(sg,0,sizeof(sg));
    for(i=1;i<=N;i++)
    {
        memset(hash,0,sizeof(hash));
        for(j=1;j<=t&&f[j]<=i;j++)
        {
            hash[sg[i-f[j]]]=1;
        }
        for(j=0;j<=N;j++)
            if(!hash[j])
                break;
        sg[i] = j;
    }
}
模板2(该模板不需要进行排序)

const int N=10008;//N为所有堆最多石子的数量
int f[108],sg[N];//f[]用来保存只能拿多少个,sg[]来保存SG值
bool hash[N];//mex{}
void sg_solve(int t,int N)
{
    int i,j;
    memset(sg,0,sizeof(sg));
    for(i=1;i<=N;i++)
    {
        memset(hash,0,sizeof(hash));
        for(j=1;j<=t;j++)
            if(i - f[j] >= 0)
               hash[sg[i-f[j]]] = 1;
        for(j=0;j<=N;j++)
            if(!hash[j])
                break;
        sg[i] = j;
    }
}

代码(使用第二个模板)

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;

const int N=10008;//N为所有堆最多石子的数量
int f[108],sg[N];//f[]用来保存只能拿多少个,sg[]来保存SG值
bool hash[N];//mex{}
void sg_solve(int t,int N)
{
    int i,j;
    memset(sg,0,sizeof(sg));
    for(i=1;i<=N;i++)
    {
        memset(hash,0,sizeof(hash));
        for(j=1;j<=t;j++)
            if(i - f[j] >= 0)
               hash[sg[i-f[j]]] = 1;
        for(j=0;j<=N;j++)
            if(!hash[j])
                break;
        sg[i] = j;
    }
}


int main()
{
    int k,m,l,num,i,j;
    while(scanf("%d",&k),k)
    {
        for(i=1;i<=k;i++)
            scanf("%d",&f[i]);
        sg_solve(k,N);
        scanf("%d",&m);
        string ans="";
        for( i=1;i<=m;i++)
        {
            int sum=0;
            scanf("%d",&l);
            for( j=1;j<=l;j++)
            {
                scanf("%d",&num);
                sum^=sg[num];
            }
            if(sum==0)
                ans+="L";
            else
                ans+="W";
        }
        cout<<ans<<endl;
    }
    return 0;
}



原文地址:https://www.cnblogs.com/vivider/p/3697663.html