九度 1526:朋友圈

刚学的并查集, 真是好用


时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:810

解决:239

题目描述:

假如已知有n个人和m对好友关系(存于数字r)。如果两个人是直接或间接的好友(好友的好友的好友...),则认为他们属于同一个朋友圈,请写程序求出这n个人里一共有多少个朋友圈。
假如:n = 5 , m = 3 , r = {{1 , 2} , {2 , 3} , {4 , 5}},表示有5个人,1和2是好友,2和3是好友,4和5是好友,则1、2、3属于一个朋友圈,4、5属于另一个朋友圈,结果为2个朋友圈。

输入:

输入包含多个测试用例,每个测试用例的第一行包含两个正整数 n、m,1=<n,m<=100000。接下来有m行,每行分别输入两个人的编号f,t(1=<f,t<=n),表示f和t是好友。 当n为0时,输入结束,该用例不被处理。

输出:

对应每个测试用例,输出在这n个人里一共有多少个朋友圈。

样例输入:
5 3
1 2
2 3
4 5
3 3
1 2
1 3
2 3
0
样例输出:
2
1


#include<iostream>
using namespace std;


int  father[10010];
void init(int *b, int len)
{
    for(int i=1;i<=len;i++)
        b[i] = i;
    return;
}
int find(int x)
{
    if(x!=father[x])
    {
        father[x] = find(father[x]);
    }
    return father[x];
}


void unineset(int a, int b)
{
    a = find(a);
    b = find(b);
    if(a==b)
        return ;
    if(a>b)
        father[a] = father[b]; 
    else
        father[b] = father[a]; 
    return;
}


int main()
{
    int n,m;
    int a,b;
    int sumb;
    while(cin>>n&&n!=0)
    {
        sumb = 0;
        cin>>m;
        init(father,n);
        for(int i=0;i<m;i++)
        {
            cin>>a>>b;
            unineset(a,b);
        }
        for(int i=1;i<=n;i++)
        {
            if(i==father[i])
            sumb++;
        }
        cout<<sumb<<endl;
    }
    return 0;
}


每天早上叫醒你的不是闹钟,而是心中的梦~
原文地址:https://www.cnblogs.com/vintion/p/4116923.html