1039 Course List for Student (25 分)

1. 题目

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N**i (≤200) are given in a line. Then in the next line, N**i student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

2. 题意

有n名学生,k门课程,给出选每门课程的学生姓名,要求最后输出每名学生选了哪些课程。

3. 思路——map+排序

创建一个map,map的键值对为<学生姓名,所选课程>,这里所选课程用一个vector来存储,因为一名学生可以选多门课程,通过题目所给的课程选择情况信息,获得每名学生所选课程,因为加入到vector中课程顺序并不是严格按照从小到大的,所以在输出结果前需要进行排序。

4. 代码

#include <iostream>
#include <map>
#include <vector>
#include <string>
#include <algorithm>

using namespace std;

int main()
{
	int n, k;	// 学生数量n,课程数量 k 
	cin >> n >> k;
	// 这里键值对表示 <学生名字, 学生所选课程> 
	map<string, vector<int>> res;
	string name;
	// 记录下每个学生所选的课程 
	while (k--)
	{
		int x, nx;
		cin >> x >> nx; 
		for (int i = 0; i < nx; ++i)
		{
			cin >> name;
			res[name].push_back(x);
		}
	}
	while (n--)
	{
		cin >> name;
		cout << name;
		vector<int> courses = res[name];
		// 根据题意,课程需要按从小到大顺序输出,所以这里需要排序 
		sort(courses.begin(), courses.end());
		cout << " " << courses.size();
		for (int i = 0; i < courses.size(); ++i)
			cout << " " << courses[i];
		cout << endl;
	}
	return 0;
} 
原文地址:https://www.cnblogs.com/vanishzeng/p/15479923.html